Chess Engine Control

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Chess Engine Control

jkexcel
v4.6.2

I'm having a problem with chess engine control.

I have selected as my chess engine Stockfish 2 thread (SF-2T), and it performs perfectly in my analysis window. However, when I choose the "+" icon to "add move", most of the time the pieces move as indicated by my selected chess engine (SF-2T). But sometimes the moves do not match. It is as if some other engine is in control. Is there a setting that forces the board to ONLY use the chess engine that I have chosen? Can I turn off this other chess engine?

PS - I've asked a similar question a year or so ago with an older version of SCID. But am hoping the current version of SCID has a new setting to stop this unexpected behavior.


------------------------------------------------------------------------------

_______________________________________________
Scid-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/scid-users
Reply | Threaded
Open this post in threaded view
|

Re: Chess Engine Control

Benoit St-Pierre
Hello,

From my experience, this comes from the fact that the engine is switching to another line while you add the variation to your game analysis.

Fulvio has written a report for the issue in the tracker:


Meanwhile, my own recommendation is to add your variation before your chess engine usually switches. The deeper the line, the more time it takes to the engine to switch. There might be a way to "slow down" your engine, but I'm not sure which UCI setting you'd need to tweak. Perhaps the "slow mover"?

Best,

B

------------------------------------------------------------------------------

_______________________________________________
Scid-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/scid-users